[Resolvido]Problema com video no Geode LX em notebook Proview PC-81001 usando tela de 1024×600 usando Ubuntu

Bem pessoal;

Para comecar o meu primeiro post segue uma solucão para o problema que muitos usuários tiveram com o notebook da empresa Proview modelo PC-81001 que não reconhecia a placa de de vídeo,pois este equipamento utiliza uma arquitetura de hardware muito fechada da AMD que é o Geode mas o problema não é fazer reconhecer a placa de video e sim o monitor  genérico já a resolucão de video dele é de 1024×600.

Bem para resolver este problema até que é simples,depois de muito eu ter pesquisado na internet né.Existe um XORG que resolve este problema e é o XORG desenvolvido pela comunidade do Ubuntu para a Proview,testei e funciona.

Segue o XORG.CONF:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "pt"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:0:1:1"
Driver "geode"
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
Option "PanelMode" "48960 1024 1064 1168 1312 600 601 604 622"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1024x600"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
DisplaySize 195 113
modeline "1024x600@60" 48.96 1024 1064 1168 1312 600 601 604 622 -HSync -VSync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
	SubSection "Display"
	Depth 24
	Virtual 1024 600
	Modes "1024x600@60"
	EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "ServerFlags"
EndSection

Copie essas informacões para o bloco de notas e salva com o nome xorg.conf e copie e depois cole dentro do diretório /etc/x11.

Caso não funcione é por que tu não tem previlégios de administrador,então tu tem que abrir um terminal e usar o seguinte comando:

sudo passwr root

ele pedirá um senha de root,digite ela 2 vezes e tu terá criado um super usuŕio,ai é só tu fazer logon ou simplesmente reiniciar,depois disso tu cola o arquivo e será muito feliz.

About João Fracassi

Técnico em Informática e Redes com amplos conhecimentos em Ubuntu e bastante experiencia em Suporte a Desktops,Laptops,Servers e também c
This entry was posted in Linux, Tutoriais e iniciantes, Ubuntu. Bookmark the permalink.

14 Responses to [Resolvido]Problema com video no Geode LX em notebook Proview PC-81001 usando tela de 1024×600 usando Ubuntu

  1. Jose junior says:

    joao… poe ai pra nos um post sobre virtualizacao de ubuntu.. na ultima vez q virtualizei ele fiquei com problemas de hd da maquina virtual.
    e nao me animo a instala um hw so pro ubuntu.. ainda dependo do windowzin
    abra’co

  2. Eduardo says:

    Boa tarde Joao!
    ë o seguinte, tenho este notebook e estava com este problema até encontrar esta soluçao em outro forum.
    A questao é, depois de aplicado este codigo, o ubuntu ficou com os menus “danificados”, sem icones, com cores solidas, e com riscos nos menus, a questao é, o que posso fazer para corrigir isso? é um problema da placa de video??

    • E ai Brother tudo bem…Infelizmente está placa de video é bem fraca e as vezes pode acontecer isso,isso só me aconteceu algumas vezes quando entrei na internet,pode ser da revisão da placa mesmo.
      Mas faça o seguinte: instala este driver http://mirror.pop-sc.rnp.br/mirror/Debian/pool/main/x/xserver-xorg-video-geode/xserver-xorg-video-amd_2.11.7-1_i386.deb e depois recria o arquivo xorg.conf exatamente como está neste tópico,ai tu loga como administrador(root) e cola o arquivo no /etc/x11,reinicia que deve funcionar.

      O meu netbook proview está funcionando perfeitamente agora,mas para ter ficado legal eu tive que fazer um reinstalação zero e ai sim aplicar o xorg.conf,ai sim bombou.
      Se der algum guru reinstala e faz a mão e sejá feliz.
      Qualquer duvida estou as tuas ordens.

  3. jose paulo says:

    Poxa to com o mesmo problema, da pra mandar de novo o Link do driver, pq esse ai nao ta funfando.

    Obrigado

  4. Alexandre says:

    Pessoal, é só comentar a linha #Option “MigrationHeuristic” “greedy”. Meu netbook tb tinha desaparecido os icones e quando eu comentei funcionou tudo normalmente.

  5. Nilton says:

    Bom dia pessoal…
    Fiz a reconfiguração do video copiando e colando esse script, funcionou de primeira.
    A resolução do video ficou perfeita, sem tela branca ou outro defeito e não tive qualquer dificulda com o navegador e paginas.
    Tive apenas que fazer a configuração para poder logar direto como root, se não nada feito, mesmo tentando no terminal via sudo, não deixava salvar o novo arquivo.
    Valeu

  6. Nilton says:

    Bom dia pessal
    Tentei essa mesma solução para a versão 10.04, não funciona.
    Ao fazer, todos os icones somem, ficando apenas as legendas, a resolucão fica ajustada em 1024×600 mas o video apresenta falhas.
    Tentei algumas modificações mas não funcionou, tive de voltar para a versão 9.04.
    .

    • Bom dia,

      Essa configuração não funciona com o Ubuntu 10.04,mas o problema é em partes pois até dá a resolução de 1024X600,mas fica com a tela pigmentada.

      Essa versão do XORG que está no meu blog funciona para qualquer equipamento de arquitetura Geode da AMD como é o caso dos netbooks proview pois eu também tenho um a 2 anos e sempre foi assim.Mas funciona no Ubuntu até a versão 9.10 Karmic Koala.Para tu não ficar tão desatualizado recomendo a instalação do mesmo que está melhor que o 9.04 e a atualização do Kernel para a versão 2.6.32 ou 2.6.33 que é a versão que eu uso.

      Se precisar de mais alguma informação estou as ordens.

  7. Nilton says:

    Para funcionar no Ubuntu 10.04, localize esta linha no xconf e comente,
    ficando deste jeito.

    # Option “MigrationHeuristic” “greedy”

    Fiz o teste e funciona perfeito.

  8. JOSE says:

    por favor me ajude.eu estou com mesmo problema e eu nao sei segar neste root,
    por favor me ajude.

    • José, desculpe a demora para responder, preciso saber o que acontece com o teu netbook para que eu possa te ajudar com uma solução.
      Preciso de mais detalhes, obrigado.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s